MegaMek/MekWars client freezes upon entering server

Issues with the server software (not campaign)

Moderators: Torren, Moderators

Post Reply
User avatar
Rooster
Posts: 5
Joined: Thu Mar 17, 2011 8:22 am

MegaMek/MekWars client freezes upon entering server

Post by Rooster » Fri Mar 18, 2011 1:27 am

Any time that I attempt to connect to a ded with another person who has attacked me, the entire client freezes up. It doesn't freeze if the other person is not attacking me, or if I am not activated. Any ideas? I'm running 3.3.1 on ubuntu karmic.

User avatar
Rooster
Posts: 5
Joined: Thu Mar 17, 2011 8:22 am

Post by Rooster » Sat Mar 19, 2011 3:44 am

Hmm... Well I did manage to get one game working, but it was only when another person hosted. It seems to have the same problem in reverse when I host, and when it is a ded, it frezes while trying to load my units. But it must not be a port thing since I could play somebody else.

Tuco
MegamekNET Campaign Operator
Posts: 2815
Joined: Wed Feb 13, 2008 10:23 pm

Post by Tuco » Sat Mar 19, 2011 11:04 pm

it seems to freeze when loading the mekwars-configured megamek settings when entering a ded for himself or for the other player when Rooster hosts. despite his post above, he also crashed when trying to join my playerhost.

Rooster also crashed my mekwars with just joining a ded i opened through host -> start dedicated host. i never even joined the ded but when he joined and i later wanted to close the ded, everything froze. before i tried to close it, but after he had joined, everything mekwars was ok.

Rooster is using an outdated combination of ubuntu/java that worked for mekwars 9 months ago. no firewall involved.

Rooster can join the host, gets the map settings loaded from Mekwars (at least the client info says) but not any of the predefined MM settings from Mekwars. that's the point when it freezes.
When the injustice is great enough, Justice will lend me the strength needed to correct it.
None may stand against it.
It will shatter every barrier, sunder any shield, tear through any enchantment and lend its servant the power to pass sentence.
Know this: there is nothing on all the Planes that can stay the hand of justice when it is brought against them.
It may unmake armies. It may sunder the thrones of gods.
Know that for ALL who betray Justice, I am their fate... and fate carries an Executioner's Axe.

Ben
Posts: 84
Joined: Wed Sep 24, 2008 4:45 pm

Post by Ben » Sun Mar 20, 2011 6:42 pm

I've used several ubuntu and java versions (always Sun Java, Open JDK never worked for me) through the last 2-3 years and never encountered such problems. Some of the problems sound familiar, but for me they are not that bad.

I usually have lag spikes, my MegaMekNET Client freezes for a while, when I start to host or enter a ded. The same when my opponent enters.

If I'm hosting I often get kicked from my host, when my opponent enters. Sometimes I can't enter again and have to restart the host, but more often I just have to join again.

If I try to join a host without correct port forwarding, I'm not only not able to join this host, but my MegaMek Client also crashes.

Atm I'm running ubuntu 10.10 and Java 1.6.0_24. I ran ubuntu karmic coala, but I never had such problems.

User avatar
Rooster
Posts: 5
Joined: Thu Mar 17, 2011 8:22 am

Post by Rooster » Sun Mar 20, 2011 7:54 pm

The bit about the java being out of date is not entirely correct. That particular instance where I showed Tuco my java version was indeed openjdk that was out of date, but I also have the latest version of sun java installed and it gives the same result. I think the problem has something to do with either my modem (which I doubt because I think it is in bridged mode, no way to tell as it has no config interface), or my ISP is doing something funny with my ports I don't know about. I'm heading back to school today so I'll see what happens on another ISP.

Post Reply