Pushing on Ice seems to be working incorrect

Issues with the game engine (not campaign)

Moderators: BeeRockxs, Moderators

Post Reply
User avatar
Windschreiter
Posts: 107
Joined: Sat Feb 16, 2008 1:07 am

Pushing on Ice seems to be working incorrect

Post by Windschreiter » Wed Aug 09, 2017 12:34 pm

Had a game versus Ostsol on Ded "Blitzkreig" saved the game as "pushing.sav" on the server

here's what happened:

Code: Select all

    Pushing Trebuchet TBT-7K (ostsol); needs 8, rolls 11 : succeeds: target is pushed into hex 1723.

Trebuchet TBT-7K (ostsol) must make a piloting skill check (entering Depth 1 Water).
Needs 4 [5 (Base piloting skill) - 1 (entering Depth 1 Water)], rolls 6 : succeeds.
    Trebuchet TBT-7K (ostsol) is displaced into hex 1723.


Trebuchet TBT-7K (ostsol) must make 1 piloting skill roll(s) (was pushed).
The base target is 9 [5 (Base piloting skill) + 4 (Ice)].
    Roll #1, (5 (Base piloting skill) + 4 (Ice) + 0 (was pushed)); needs 9, rolls 7 : falls.
    Trebuchet TBT-7K (ostsol) falls on its rear, suffering 5 damage.
        Trebuchet TBT-7K (ostsol) takes 5 damage to RA.
            5 Armor remaining.

Pilot of Trebuchet TBT-7K (ostsol) "Tai-i Toshiro Genji" must roll 9 to avoid damage; rolls 10 : succeeds.
Behaviour:
The TBT has been displaced after the succesful push, but the Hex seems to be treated as "water" - it was ice with depth 1 below. After that came the PSR for being pushed modified by ice.

Expected behaviour:
On entering the Ice Hex there should've been a breach roll and depending on that roll either a PSR for entering water then for beeing pushed (modified by water) OR a PSR for beeing pushed (modified by ice)

User avatar
wildj79
Posts: 85
Joined: Wed Aug 26, 2009 11:31 pm
Location: Texas

Re: Pushing on Ice seems to be working incorrect

Post by wildj79 » Sat Aug 26, 2017 11:48 pm

I've looked into this a little, and it seems that it is more of a problem with displacement events in general, than with pushing specifically. I'm going to write up a bug report on the MM github page.

User avatar
Windschreiter
Posts: 107
Joined: Sat Feb 16, 2008 1:07 am

Re: Pushing on Ice seems to be working incorrect

Post by Windschreiter » Mon Aug 28, 2017 6:58 am

Thank you!

User avatar
wildj79
Posts: 85
Joined: Wed Aug 26, 2009 11:31 pm
Location: Texas

Re: Pushing on Ice seems to be working incorrect

Post by wildj79 » Mon Aug 28, 2017 2:47 pm

Posted to Megamek issue tracker here.

Post Reply