Some noticed oddities regarding the new 0.36.0 stable

Topics related to the game engine (not campaign)

Moderators: BeeRockxs, Moderators

Post Reply
User avatar
Darth Razorback
Posts: 66
Joined: Sat May 02, 2009 8:05 pm

Some noticed oddities regarding the new 0.36.0 stable

Post by Darth Razorback » Mon Nov 18, 2013 8:49 am

1: (minor) The game itself says it's 37.0, not 36.0. Which is accurate?
2: (minor-amusing) I had a Bot taking an impossible shot at an ejected Mechwarrior who was standing behind and adjacent to a level 1 hill. Both attacker and target were on lvl 0 terrain. Unless that mechwarrior was a Zentradi pilot, I don't think he should have registered as tall enough to see.
3: (moderate-annoying but not game impacting) If I modify a custom mech and re-save it to it's custom directory, it starts to have multiple listings in the mech selection tables, even though there's only one actual copy of the mech on the hard drive. Is there some way to clean up these 'ghost' units without having to reinstall the software?
4: (moderate-game time impacting) I was over at a friend's house, and watched him set up the game configuration options three times because it would not save them. Haven't tested this one at home yet. Is there a known cause/fix for this?
5: (moderate-impacts mech selection) An inner sphere Streak-6 SRM should be later technology than 2750? The game year on the mech did not update to the relevant year of the most advanced tech on it. It did before I'm pretty sure. Unknown if this is limited to that particular piece of gear or if it's a sign of a larger problem. I could also be wrong on the year, but I think 2750 was just Streak 2's.

BeeRockxs
MegamekNET Moderator
Posts: 988
Joined: Thu Feb 14, 2008 12:49 am
Location: Cologne, Germany
Contact:

Re: Some noticed oddities regarding the new 0.36.0 stable

Post by BeeRockxs » Mon Nov 18, 2013 2:08 pm

1) 0.36.0. I made a typo when creating the release.
2) Yeah, there are still some bugs with the bot.
3) Delete units.cache in data/mechfiles
4) That's the first time I heard about this.
5) The datafile of the unit in question needs to note the design year. The year is not automatically generated based on the introduction date of the equipment.

User avatar
Darth Razorback
Posts: 66
Joined: Sat May 02, 2009 8:05 pm

Re: Some noticed oddities regarding the new 0.36.0 stable

Post by Darth Razorback » Mon Dec 02, 2013 11:30 am

Thanks, especially for #3. I think I have an answer for you for #4 though. He had a password set for some reason (he's the twitchy type) and because he didn't have a matching password in place it didn't save his configurations. Or something like that. I'll have to talk to him about that again and see if I can get a clearer answer for you. Actually meant to post this in the bug forum, this was an accident. Thank you guys again for all the hard work you've put into this project over the years!

arlith
Posts: 176
Joined: Tue Dec 03, 2013 4:54 am

Re: Some noticed oddities regarding the new 0.36.0 stable

Post by arlith » Thu Dec 05, 2013 12:02 am

While deleting the unit.cache helps alleviate #3, there was actually a bug that was causing that which is now fixed.
Member of the MegaMek Team.

Post Reply