Terrain types not loading

Issues with the server software (not campaign)

Moderators: Torren, Moderators

Post Reply
User avatar
TigerShark
Mekwars Server Operator
Posts: 702
Joined: Wed Feb 24, 2010 8:28 am

Terrain types not loading

Post by TigerShark » Wed Feb 13, 2019 4:06 pm

I've added two new terrain types to my "terrain.xml" file (still using pre-weather terrain file), but new terrain is not appearing in the dropdown for the planet editor.

I've restarted the server several times, but it still doesn't appear.

EDIT: Are there a maximum number of terrain types you can put into the terrain.xml file? When I put one in, now another disappears, and so on.

User avatar
TigerShark
Mekwars Server Operator
Posts: 702
Joined: Wed Feb 24, 2010 8:28 am

Re: Terrain types not loading

Post by TigerShark » Wed Feb 13, 2019 6:06 pm

terrain.zip
(6.66 KiB) Downloaded 2 times
Can't figure out what's wrong. Something is amiss and killing all of the terrain beneath it...

Ironboot
Mekwars Server Operator
Posts: 204
Joined: Tue Apr 27, 2010 5:00 am
Location: Boston, MA

Re: Terrain types not loading

Post by Ironboot » Wed Feb 13, 2019 8:22 pm

At what terrain does it stop at?


For example if you have Terrain named... A, B, C, D, E, F, G, H, I, J, K, L and everything from F to L is missing. From my experience is that I messed up on E.

Ironboot
Mekwars Server Operator
Posts: 204
Joined: Tue Apr 27, 2010 5:00 am
Location: Boston, MA

Re: Terrain types not loading

Post by Ironboot » Wed Feb 13, 2019 8:45 pm

In <NAME>Light Urban</NAME>.. <THEME></THEME> Nothing is in theme. Not sure if that is the problem?

Same with <NAME>Industrial Ruins</NAME> <THEME></THEME>

User avatar
TigerShark
Mekwars Server Operator
Posts: 702
Joined: Wed Feb 24, 2010 8:28 am

Re: Terrain types not loading

Post by TigerShark » Wed Feb 13, 2019 8:56 pm

It defaults to "boring" with no theme.

Turns out you're right. I just put the problem children at the end and replaced them with one that works, transcribing the numbers. I'm guessing it was either the order or a missing bracket. Bizarre...

Spork
Mekwars Developer
Posts: 3879
Joined: Wed Feb 13, 2008 10:23 pm

Re: Terrain types not loading

Post by Spork » Mon Feb 18, 2019 3:54 am

MekWars is coded to handle certain terrains. It's not really meant to handle custom ones.

More and more, I'm considering starting over.
Never had much, grew up with nothing
But the music, well it was something
Been down and out, I've been on top of the world,
World that keeps on spinning on a turntable.

User avatar
TigerShark
Mekwars Server Operator
Posts: 702
Joined: Wed Feb 24, 2010 8:28 am

Re: Terrain types not loading

Post by TigerShark » Mon Feb 18, 2019 7:01 am

I did get the terrain configurations I made to work. It was just (from what I can tell) a missing "<" bracket in the list, I believe.

:)

Post Reply